Email notifications delay
Incident Report for Shotgun Software
Resolved
We have fixed the issue and affected sites have received all their delayed email notifications.
Posted 15 days ago. Sep 03, 2019 - 18:52 UTC
Investigating
We are currently investigating some delay in email notifications. It only affect a few sites.
Posted 15 days ago. Sep 03, 2019 - 17:50 UTC
This incident affected: Notification Service.