Trial Site Issue
Incident Report for Flow Production Tracking
Resolved
An issue with the server hosting the Public Web site was discovered and fixed. Trials are working as expected again.
Posted Jul 11, 2017 - 17:33 UTC
Investigating
It is currently impossible to sign up for a new Shotgun Trial. We are currently investigating the issue.
Posted Jul 11, 2017 - 14:51 UTC